Workflow error

May 16, 2011 at 9:25 AM

I'm using the Editorial Collaboration Framework, I've got it instaled in my server and it works fine, but when I try to start publishing one story trhough "Produce Story" it returns an error and the workflow stops.

I've tried to change several security options, and I've checked the site config and all seems to be correct, but the error continues happening.

Anyone have suffered any similar problem?
Any idea about the solution about the workflow error?

Thanks

May 18, 2011 at 8:50 AM

Hello,

can you tell me the error message? Does the error occurs after clicking the link "produce Story" or if you click "yes" on the initiationform of the workflow?

What is the url of the "Produce Story" link?

Best regards,

Sven

May 18, 2011 at 11:03 AM

I haven't any error message, only "Workflow error"

I go to the stories page, I select the story, later I click in "Workflows" and I use the link "Produce Story", after this I'm send to another page that says:
"Do you really want to create a new Story?"
and I select the "OK" button

Then, nothing occurs and I'm again in the stories page, but in the right side of my story I can see under "Produce Story" column: "Error Ocurred"
If I click in the workflow and over "View workflow reports" I only obtain an error page with this text: "The specified web does not contain a reporting metadata list."

The "Produce Story" link is:

http://ocs:8572/_layouts/ECP.Sharepoint.Workflow.Forms/Instantiation/InstantiationForm.aspx?List=d9f013a5-26af-41fa-ad45-d41db21f5f9e&ID=2&TemplateID={649c9a8c-2307-492c-b88f-4ae425736031}&Source=http%3A%2F%2Focs%3A8572%2FLists%2FStories%2FAllItems%2Easpx

Thank you for your attention,
Daniel

May 18, 2011 at 12:22 PM

Hello Daniel,

can you please test, if the workflows starts doing the following:

  • Go to page stories
  • Do not select a story item, but click on the link (Produce Story) in column "Story workspace" of the story that shall be produced. This link is the url to start the workflow.

does it work now or do you have not such a link?

Best...

Sven

 

May 18, 2011 at 2:06 PM

Hello,

 

In the page stories when I create a new item, I haven't any link in the column "Story workspace", but in the home there is a link in the "My Stories" webpart under the "Story workspace" column with the text "Produce Story" and the next link:

http://ocs:8572/_layouts/ECP.Sharepoint.Workflow.Forms/Instantiation/InstantiationForm.aspx?List=d9f013a5-26af-41fa-ad45-d41db21f5f9e&ID=3&TemplateID=649c9a8c-2307-492c-b88f-4ae425736031&Source=http://ocs:8572/pages/story.aspx

When I click it, I'm send to the page that says:
"Do you really want to create a new Story?"
here I select the "OK" button and I'm now send to:

http://ocs:8572/pages/story.aspx

Here I can see my story, if y click again in the link "Produce Story" (before nothing occurs) I obtain an error page (http://ocs:8572/_layouts/Error.aspx?ErrorText=The%20workflow%20failed%20to%20start%20because%20a%20previous%20workflow%20of%20this%20type%20is%20still%20active%20and%20has%20yet%20to%20be%20completed%2E) with the text: "An error has occurred on the server."

Since here, on page "Stories" in the column "Produce  Story" I have a link with the text: "Error Occurred"

So different way but same result.

 

Regards,

Daniel

May 18, 2011 at 2:28 PM

Hello,

because the list My Stories" on Page "Home" and the lists on page Stories are the same i wonder why you only see the link on the page "Home". Maybe you can refresh the page after clicking "Propose new story" on page stories and have a look if the link appears on that page too. If yes, please check the workflow again. The workflow can take a while to complete, but if its finished the link shall change to "Open workspace".

As far as i know the the current user has to be able to create a new subsite using the template with the id in the link you posted above. Maybe you can try this manually by creating a "New Site" by opening the menu "Site Actions" and using the template with the according id, just to make sure you are not running in security issues.

Best regards....

May 18, 2011 at 5:21 PM

Ok, my fault

I've confused the column "Story workspace" with column "Produce Story" of the Stories page. I'm sorry.

But the result is the same again, in both (home and stories) I have the "Produce story" link but both of them returns the same workflow error.


I've tried to create a new site with my user using the ECP template and I can create it correctly, so I have permissions to do that.

Regards,

Daniel

May 20, 2011 at 7:51 AM

Hello Daniel,

maybe you can tell me the error message you get after starting the workflow or is there no "really" feedback? Maybe you can have a look at the log file you find in directory HIVE\Logs. Are there any "unexpected" logs in the latest file?

You can also try to remove the workflow from the stories library and associate it again.

Btw, which language is your sharepoint server? I currently assume, that the workflow does not find the template of the story workspace.

Best regards,

Sven

May 20, 2011 at 11:03 AM

Hello Sven,

There isn't any feedback or any error message, the workflows simply ends and send me to the previous page.

In my MOSS logs directory I have find this:

05/20/2011 11:46:58.67     w3wp.exe (0x1518)                           0x1C60    Windows SharePoint Services       Workflow Infrastructure           88xr    Unexpected    WinWF Internal Error, terminating workflow Id# 473648d8-6f36-4b20-8a5e-af04b5f3f274     
05/20/2011 11:46:58.67     w3wp.exe (0x1518)                           0x1C60    Windows SharePoint Services       Workflow Infrastructure           98d4    Unexpected    System.ArgumentException: File or arguments not valid for site template 'ecp_sw0112.stp'.     at Microsoft.SharePoint.SPWebTemplateCollection.get_Item(String strKey)     at ECP.Sharepoint.Workflows.ProduceStory.ProduceStory.CreateWorkspace_ExecuteCode(Object sender, EventArgs e)     at System.Workflow.ComponentModel.Activity.RaiseEvent(DependencyProperty dependencyEvent, Object sender, EventArgs e)     at System.Workflow.Activities.CodeActivity.Execute(ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecuto...     
05/20/2011 11:46:58.67*    w3wp.exe (0x1518)                           0x1C60    Windows SharePoint Services       Workflow Infrastructure           98d4    Unexpected    ...rOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)     at System.Workflow.Runtime.Scheduler.Run()    

¿Can you see anything significative?

I work in Spain but all my software's language is english, so I suppose it shouldn't produce any error.

How I can associate a new workflow? I access to "view all site content" and I have only a list of "Stories" but no libraries

Best regards,

Daniel

May 20, 2011 at 3:21 PM

Hi Daniel,

you can associate a new workflow to the stories list by clicking Workflow settings in the library settings. Then you can choose "Add workflow" and associate the "Produce story workflow" (I assume you can only add it after removing the current one). After adding you should be routed to the association form where you have to choose the story template. Here you should find the "ec storyworkspace" template.

What i am wondering is, why you only see the stories list in "View all site content". This would mean the installation did not work correctly.

Best regards,

Sven 

May 23, 2011 at 3:13 PM

Ok, I think here is the problem!!!

I've accessed to the "Workflow settings" in my stories "list settings" and after deleting the actual workflow, I've added a new one associating the "Produce story workflow", but I've seen that I haven't any template in the box with the text: "Choose a Workspace-Template:" so I suppose this is why it is failing.

Where can I obtain a correct template or how can I install it?

Thanks a lot,

Daniel

May 23, 2011 at 3:17 PM

I've tried to install the content of "WSP-ECP -> 07_SiteTemplates" folder of my instalation package but it says "Web template with file ECP.stp already exists".

Best regards,

Daniel

May 23, 2011 at 3:45 PM

I got it!

I have uploaded manually the ecp.stp to my "site template gallery" and to my "list template gallery", then I've seen that in my workflow settings appears the template, I've selected it and after this the workflows works correctly.

Now I got a new problem, when I click "Open Workspace" it sends me to the next URL: "http://myserver/sw5/pages/storytab01.aspx" but this page doesn't exists. The site sw5 is properly created and I can use it, but this concrete page doesn't exists,  so the redirection of my home page is worthless.

 

Best regards,

Daniel

May 23, 2011 at 4:07 PM

Hi Daniel,

this sounds better now, but now it seems that the "Produce Story " workflow creates a new subsite on base of the rootsite (ECP-Template).

Can you try to select the ECP_SW...-Template on Workflow association, because this template includes the storytab01.aspx.

Best regards,

Sven

(Maybe you didn t saw the Templates on workflow association because of language issues.)

 

May 23, 2011 at 4:30 PM

Perfect,

The ECP_sw0112.stp works fine, so I have all working correctly.

 

Thanks for such valuable  support

Best regards,

Daniel